問題描述:項目中使用vue-i18n在控制臺中顯示以下警告。

You are running the esm-bundler build of vue-i18n. It is recommended to configure your bundler to explicitly replace feature flag globals with boolean literals to get proper tree-shaking in the final bundle.

解決方法:在vite.config.ts中加入如下配置

alias: {
    'vue-i18n': 'vue-i18n/dist/vue-i18n.cjs.js',
  },
最后修改:
如果覺得我的文章對你有用,請隨意贊賞。